View Issue Details

IDProjectCategoryView StatusLast Update
0000082Volume 2Bugpublic2019-07-26 10:24
ReporterTafferAssigned ToCattan 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionIssue 1 
Target VersionIssue 2Fixed in Version 
Summary0000082: AuthServer duplicates zlib for its arda2 library
DescriptionAuthServer/external has bzip2 and a duplicate of zlib; it should build against 3rdparty/zlibsrc instead. Also, bzip2 should be moved into 3rdparty... ideally all of the 3rd party code we need to keep up to date should be in one spot.

Both of these are woefully out of date (1.2.3 from 2005 vs. 1.2.11 from 2017) too.
Steps To ReproduceLook in 3rdparty, see zlibsrc; look in AuthServer/external, see zlib.
TagsNo tags attached.
subsystem

Activities

Cattan

2019-07-26 10:24

administrator   ~0000121

Fixed in VS2019 port

Issue History

Date Modified Username Field Change
2019-05-13 10:25 Taffer New Issue
2019-07-26 10:20 Cattan Assigned To => Cattan
2019-07-26 10:24 Cattan Status new => resolved
2019-07-26 10:24 Cattan Resolution open => fixed
2019-07-26 10:24 Cattan Note Added: 0000121