View Issue Details

IDProjectCategoryView StatusLast Update
0000253Volume 2Featurepublic2020-02-28 01:36
ReporterChetAssigned Tozalittle 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionIssue 2Fixed in VersionIssue 2 
Summary0000253: Customizable Aggro Cap Modes
DescriptionProvide changes to allow the use of “AggroCap” and “TargetCapMode” in servers.cfg and passes these along to mapserver via launcher parameters. AggroCap should be set below 200, otherwise it may cause crashes due to an overflow. TargetCapMode expects an integer of 1, 2, or 3. Any other number uses the default settings. TargetCapModes are as follows:

1 - Defaults to whatever is specified in the power file
2 - Scaled to a percentage of max aggro cap (Default specified in power file divided by 17 times
the aggrocap [ppow->MaxTargets/17*AggroCap] which should provide x% of the aggrocap based on
the original powers cap in relation to the original aggro cap of 17)
3 - TargetCap = AggroCap
TagsNo tags attached.
subsystemDBServer, MapServer

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-02-28 01:36 Chet New Issue
2020-02-28 01:36 Chet Assigned To => zalittle
2020-02-28 01:36 Chet Status new => resolved
2020-02-28 01:36 Chet Resolution open => fixed
2020-02-28 01:36 Chet Fixed in Version => Issue 2