View Issue Details

IDProjectCategoryView StatusLast Update
0000239Volume 2Featurepublic2019-10-30 22:56
ReporterBubbleWrapAssigned ToBubbleWrap 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product VersionIssue 2 
Target VersionIssue 2Fixed in VersionIssue 2 
Summary0000239: Allow client to specify which servers it wants Authserver to display
DescriptionPrior behaviour of AuthServer is that each account is assigned to one or more server groups, and each server is assigned to one server group. When a client connects, Authserver sends it a list of all servers in groups the account is assigned to, and also all servers in group 0. This behaviour is presumably intended for scenarios where you have different shard groups, such as the US and EU shards of the live era.

With these changes, the client can optionally ask authserver for specific groups instead. If the client does not request groups, the Authserver uses the original behaviour above. If groups are requested, Authserver sends a list of servers in those groups, regardless of what groups the account is assigned to. This allows for the more common use-case now where a live and QA shard are running off the same Authserver to share accounts, but due to data differences you don't want the QA shard to be selectable when logging in using the live client or vice-versa. By setting the QA server into a different server group and having the QA client request that group, it will prevent the second shard showing up.
TagsNo tags attached.
subsystemAuthServer

Activities

BubbleWrap

2019-10-30 22:56

developer   ~0000162

Merged into develop.

Issue History

Date Modified Username Field Change
2019-10-26 17:21 BubbleWrap New Issue
2019-10-26 17:21 BubbleWrap Assigned To => BubbleWrap
2019-10-30 22:56 BubbleWrap Status new => closed
2019-10-30 22:56 BubbleWrap Resolution open => fixed
2019-10-30 22:56 BubbleWrap Fixed in Version => Issue 2
2019-10-30 22:56 BubbleWrap Note Added: 0000162